@Overrideでエラーが出るときの対処

2011年1月5日

@Overrideでエラーが発生する場合の対処方法

このようなエラーが発生する場合

エラーの内容としては「スーパークラスのメソッドをオーバーライドする必要がある」ですが、ソース上ではしています。

で、このソース、ほかのeclipse環境で見るとエラーが出なかったりするので、環境かな~と調べていたら、エラーが出る環境は

Compiler compliance level:というのが1.5になっておりました。

この項目は

[Window] – [Preferences] – [java] – [compiler]

の中にあります。

これとは別に、プロジェクトにも同様の設定があり、こちらも1.6にすることで

@Overrideのエラーは解消できます。

アンケート